前幾天被 Palemoon 通知更新到 25 之後就一直覺得怪怪的,不過因為一直處於忙碌狀態,沒有深究那些小事,昨天才從 Palemoon 官網大致了解了怎麼回事。

簡而言之,自 Palemoon 25 之後不再使用和 Firefox 相同的識別碼,所以有些網站可能會將 Palemoon 視為某種未知的瀏覽器,只提供非常保守版本的網頁,有些網站甚至完全不能使用,只跑出提醒使用者安裝最新版瀏覽器的頁面。

我還不知道 Palemoon 做出這項決定的原因。官網建議的解決的方案為:

  1. 寫信給網站經營者,請他們偵測瀏覽器的時候考慮 Palemoon。
  2. about:config 下,將 general.useragent.compatMode.firefox 改為 True。這個選項在將來 Palemoon 25.0.2 推出後會預設為 True。這個做法有點小問題,因為 Palemoon 字面上的版本號比 Firefox 低許多,因此網站可能會以為你用的是比較早期版本的 Firefox。
  3. 同樣到 about:config 下,針對個別網站加入 general.useragent.override.[網域] 設定字串,如:
general.useragent.override.addons.mozilla.org

內容如:

Mozilla/5.0 (Windows NT 6.1; WOW64; rv:24.9) Gecko/20100101 Firefox/24.9 PaleMoon/24.9

必須針對有問題的網站一個一個設,有點麻煩。官網認為方法 3 有其必要,是因為還可以順便指定網站所認可的瀏覽器版號,這是方法2無法做到的。

詳見: https://forum.palemoon.org/viewtopic.php?f=24&t=6004

novus 發表在 痞客邦 PIXNET 留言(0) 人氣()